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Scheduling the Upgrade

Scheduling the Upgrade

Upgrading from Platform Releases pre-8.0

When upgrading from a Platform Release prior to 8.0 to Platform Release 8.0 or later, OneStream
encourages customers to prepare for their upgrade by referencing content in the ONECommunity
Platform v8+ Upgrades Group and by reaching out to their Customer Success representative.

OneStream Cloud customers may initiate Platform Release 8.0 or later upgrade interest by
submitting a Software Upgrade request through the Service Catalog. Requests will be routed to
the corresponding Customer Success representative who will reach out to discuss preparation
activities required for upgrade readiness.

OneStream self-hosted customers may download Platform Release 8.0 or later from Solution
Exchange, but are also encouraged to engage their Customer Success representative to review
preparation activities to ensure a successful upgrade.

Upgrading from Platform Release 8.0

Upgrades from Platform Release 8.0 to 8.1 or later follow traditional OneStream best practices.
Cloud customers can initiate and schedule upgrades through the Software Upgrade request on
the Service Catalog, which will be followed by a scheduling request.

OneStream self-hosted customers may download Platform Release 8.1 directly from Solution
Exchange and proceed with their upgrade.
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Requirements

Requirements

Information Technology professionals responsible for installing, maintaining and supporting
OneStream, must satisfy the following requirements to best support an upgrade. They must also
review the requirements and special notes in the Installation and Configuration Guide and
Release Notes.

IMPORTANT: Platform Release 8.0 and later was developed using Microsoft NET 6 .
As a result, all Business Rules must be tailored for .NET 6. For more information, see
Platform Release 8.0 or Later Readiness.

+ OneStream Platform Release 8.0 or later requires Microsoft .NET 6.
° App Server and Web Servers

o |nstall the latest version of ASP.NET Runtime (Hosting Bundle) (minimum
v6.0.14).

o |nstall the latest version of .NET Desktop Runtime (x64) (minimum v6.0.14).

° Client

o |nstall the latest version of .NET Desktop Runtime (x64) (minimum v6.0.14).

* OneStream Servers requires IS 7 or later.

* In each application, complete the Compile all Business Rules and Formulas to verify
that business rules use the proper syntax.

 If your applications are referencing any 3rd party DLLs that are not provided by OneStream,
verify these DLLs are .NET 6 compatible. Contact OneStream Support
(support.onestreamsoftware.com) to discuss available upgrade options.

* When upgrading OneStream, ensure to update the database schema if an update is
available. We recommend full database backups.

» Backup the Configuration files in your OneStream Share directory.

« For additional minimum system requirements, see Hardware and Software Requirements
in the Installation and Configuration Guide.
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Requirements

* When implementing SIC with the OneStream application, see Requirements in the Smart
Integration Connector Guide.

IMPORTANT: Self-hosted customers must have a successful database connection
prior to the Database Upgrade. See Enable the Trust Server Certificate.
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Before Upgrading

Before Upgrading

Perform these tasks before upgrading:
1. Perform a full backup of all OneStream databases.

2. Download the OneStream installation package from the Solution Exchange:

a. Login to the Solution Exchange and select Platform to get the latest version of
OneStream.

b. Download the appropriate On-Premise package to get the appropriate setup files for
the server installation.

3. Verify the location of the OneStream configuration files:

a. On a OneStream server, select Start > Programs > OneStream Software > Server
Configuration Utility.

b. Right-click the utility and select Run as Administrator.

c. Select File > Open ASP.NET Configuration File and browse to the appropriate
location.

¢ On web servers: C:\Program Files\OneStream Software\OneStream
WebRoot\OneStreamWeb and select appsettings.json.

* On application servers:C:\Program Files\OneStreamSoftware\
OneStreamAppRoot\OneStreamApp and select appsettings.json.
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Before Upgrading

d. The file opens and displays the path to the XFAppServerConfig.xml and
XFWebServerConfig.xml configuration files.

#7 OneStream Server Configuration - 0O X
File  Tools
Server Config Form x
H 2

OneStream Configuration Folder

ChOneStreamShareh\Config

e. Copy and paste the path to the configuration file. You will specify this location during
the upgrade.

I NOTE: This path is commonly set to C:\OneStreamShare\Config

4. Forabackup, copy these configuration files.
5. Close the file without saving and exit the utility.
6. Verify the OneStream service account in Internet Information Services Manager:

a. The service account must be an Admin ID or in the IIS_IUSRS Group, Performance
Log User and Performance Monitor Users group. The ID is required for queuing and
CPU monitoring.

b. Oneach OneStream server, select Start > Control Panel > Administrative Tools >
Internet Information Services (lIS) Manage.

c. Expand the server and select Application Pools. This displays application pools to
the right. The OneStreamAppAppPool and OneStreamWebAppPool service
accounts display in the Identity column. Note the Windows account and password as
you will enter them in IIS after the upgrade.

7. Verify the availability of the OneStream Application Server where:
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Before Upgrading

* The OneStream Database Configuration Ultility is installed: On each OneStream
application server, click Start > Programs> OneStream Software and verify that
the OneStream Database Configuration Utility is installed.

* OneStream is installed: On each OneStream application server,
Start > Programs> OneStream Software to verify that OneStream is installed.

8. Install the following :
¢ App Server and Web Servers

o |nstall the latest version of ASP.NET Runtime (Hosting Bundle) (minimum
v6.0.14).

o |nstall the latest version of .NET Desktop Runtime (x64) (minimum v6.0.14).

¢ Client

° Install the latest version of .NET Desktop Runtime (x64) (minimum v6.0.14).

9. On-prem customers must enable the Trust Server Certificate for the following:
OneStream Database Server

From the OneStream Server Configuration Ultility:

a. Locate Database Server Connections.

b. Click "' to open the Database Server Connections.
c. Add "Trust Server Certificate=True" to the end of the Connection String.

d. Click OK.
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Before Upgrading

¥ OneStream Server

File  Tools

Application Server Configuration File - C:\OneStreamShare\Config\XFAppServerConfig.xml|

H B
Maximum Number of Unsuppressed Rows Per Cube View Page 2000 -
Maximum Number of Seconds To Process a Cube View 40

El Databases

Database Server Connections (Callection)
Framework Database Server Connection OneStream Database Server
REWELEILEELEESERR () Database Server Connections

State Database Server Conni

Onestream Database Serve *

State Database Schema Nani |i‘ Bl Connection String Settings
B External Systems Revenue Mgmt System Py Command Timeout 90
Revenue Mgmt System 202 Command Timeout Large 900

External System Connecticn |T‘
H Languages Payment Mgmt System . Connection String Max Pool Size=1000;Cannect Timeout=6( Trust Server Certificate=True

Payment Mgmt System 202

Culture Codes | ‘ Is Connection String Encrypted False

T — OneStreamEmail B Remote Editing
Server Sets 2'25::1:::‘:29 . Enable Remote-E.diting - True

El Task Activity “ N Use Remate Editing Settings True !
Log Books

0K H Cancel ‘
Log Cube Views -

All Application Databases

From the OneStream Database Configuration Utility:
a. Right-click on a database, click Edit the Database Configuration.
b. Select Advanced.

c. Set Trust Server Certificate to True, then click OK.

WA OneStream Database Configuration

File  Tools
4 Databases @ Advanced o x
OneStream_BBR_Student (localhost) Min Pool Size -
OneStream_Framework (localhost) Pool Blocking Period
Onestream_GolfStreamDemo_2022 (lo¢  Pooling
B Replication
Replication
B Security

Enclave Attestation Url
Encrypt

Integrated Security
Password

Persist Security Info

User ID

B Source

AttarhDhEilanana v
Refresh Connection String

Connection Strina

Upgrade Guide 7



Before Upgrading

d. Select Test Connection to ensure a successful connection.

() Edit Database Connection

Database Server localhost | |

® Use Windows Authentication
Use SQL Server Authentication
User Name

Password
Database OneStream_Framework | |

| Test Connection |

oK || Cancel |

NOTE: Alternatively, set the Trust Server Certificate to True directly in the
XML.

3;Max Pool Size=1000;Connect Timeout=60)TrustServerCertificate=Trues]]3</ConnectionString>

Repeat these steps for all Application Databases.
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Upgrade System Components

Perform the tasks in the following sections - in order, to upgrade the complete OneStream system.

Uninstall OneStream Servers

1. Select Control Panel > Programs and Features > Uninstall a Program and locate the
OneStream Servers component.

2. Right-click OneStream Servers and select Uninstall.

Uninstall OneStream Client API

1. Select Control Panel > Programs and Features > Uninstall a Program and locate the
OneStream Client APl component.

2. Right-click OneStream Client APl and select Uninstall.

Re-Install OneStream Servers on an Application Server

This is the primary installation package that performs a complete server setup, including the web
server, application server and all utilities. You can perform a custom install to choose the
appropriate server components.

1. Browse to the OneStream Servers package, right-click OneStreamServers-#.msi and
select Install to run the server installation.

2. Click Next on the landing page and accept the License Agreement.
3. Specify the directory where the software was previously installed and click Next.
4. Select Custom and click Next.

5. On Select Features, choose Application Server and Server Configuration Utility and
click Next.

NOTE: Choose the Database Configuration Utility and Upgrade Assistant
Utility if the application server is the server where the Database Configuration
Utility was previously installed.
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Upgrade System Components

6.

ﬁ%‘ OneStream Servers Setup - x

Custom Setup
Select the way you want features to be installed. @

Click the icons in the tree below to change the way features will be installed.

— Qvl Application Server

e X -| web Server

- X _~| Server Configuration Utility

-------- Database Configuration Utili

f X | Upgrade Assistant Utility

This feature requires 350MB on your
hard drive.

Reset Disk Usage Back Next Cancel

Click Install then Finish.

Re-Install OneStream Servers on a Web Server

1.

Browse to the OneStream Servers package, right-click OneStreamServers-#.msi and
select Install.

Click Next and accept the License Agreement.

Specify the directory where the software was previously installed and click Next.

. Select Custom and click Next.

On Select Features, choose Web Server and Server Configuration Utility and click
Next.
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Upgrade System Components

ﬁ OneStream Servers Setup - X

Custom Setup
Select the way you want features to be installed. @

Click the icons in the tree below to change the way features will be installed.

o X v| Application Server
: Qvl Web Server

- =3 -| Server Configuration Utility

i E Database Configuration Utili

‘.. X _-| Upgrade Assistant Utility

This feature requires OKB on your
hard drive.

Reset Disk Usage Back MNext Cancel

6. Click Install then Finish.

Re-Install OneStream for Desktop

1. Browse to the OneStream package, right-click OneStreamDesktop-#.msi and select
Install.

2. Click Next and accept the License Agreement.

3. Select Custom and click Next.

4. Select the directory where the software was previously installed and click Next.
5. On Select Features, select all options and click Next.

6. Click Install then Finish.

Upgrade the Framework and Application Databases

Before performing these steps, have a database administrator back up all OneStream databases.
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Upgrade System Components

. On the OneStream application server with the OneStream Database Configuration Utility

installed, select Start > Programs > OneStream Software > OneStream Database
Configuration Utility.

. Right-click the utility and select Run as Administrator.

Right-click OneStream Framework Database and choose Upgrade Database Version.

I NOTE: If this is disabled, an upgrade is not required.

NOTE: If you get an error, check the log for details: C:\Program
Files\OneStream Software\XFDatabaseConfig\Log

Confirm the upgrade.

Repeat the upgrade for each Application database and the Framework database until
the option is disabled. This will indicate you have updated to the current version.

Run the Upgrade Assistant Utility

Guidance for self-hosted environments

This is an additional step for when upgrading to Platform Release 8.0 or later and must be
performed. Specifically, this version of the Upgrade Assistant Utility will convert any legacy
reports that were stored in CodeDOM format to now be stored as XML.

1.

On the OneStream application server with the OneStream Upgrade Assistant Utility
installed, select Start > Programs > OneStream Software > OneStream Upgrade
Assistant Utility.

From the command line enter:

xfupgradeassistant -c C:\OneStreamShare\Config\XFAppServerConfig.xml -t
ReportLayoutBytes -v -update

NOTE: C:\OneStreamShare\Config is the default path to the configuration
file. You must update this path if it has been modified for your environment.
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Upgrade System Components

3. Enter exit to close the utility.

4. RestartllS.

Update the ASP.NET Configuration File

The ASP.NET Configuration file (appsettings.json) must be updated on every server / folder as
outlined below:

¢ Application server

° C:\Program Files\OneStream
Software\OneStreamAppRoot\OneStreamApp\appsettings.json

* \Web servers:

° C:\Program Files\OneStream
Software\OneStream\WebRoot\OneStreamWeb\appsettings.json

° C:\Program Files\OneStream
Software\OneStream\WebApiRoot\OneStreamWebApi\appsettings.json

1. On each OneStream server, launch the OneStream Server Configuration Utility by clicking
Start > Programs > OneStream Software > Server Configuration Utility.

2. Right-click the utility and select Run as Administrator.

3. Choose File > Open ASP.NET Configuration File and browse to the appropriate location
from the folders above.

4. Selectthe appsettings.json file.
5. When the file opens, copy the directory path of the configuration files.

I NOTE: This path is commonly set to C:\OneStreamShare\Config

6. Enable HTTP and Enable HTTPS are enabled by default. Change when applicable.
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Upgrade System Components

7.

8.

ﬂf OneStream Server Configuration

File Tools

ASP.NET Configuration File - C\Program Files\OneStream Software\OneStreamWebRoot\OneStreamWeb\appsettings.json
H 2

OneStream Configuration Folder
C\OneStreamShare\Config

= Enable HTTP

B Enable HTTPS

NOTE: Clear Enable HTTP when SSL is enabled or clear Enable HTTPS
when SSL is not enabled.

Save and close the file.

Repeat these steps on each web and app server in the environment.

Update the Configuration Files

1.

2.

Open the Application Server Configuration file and select File > Save.
Close and re-open the same file.

In Database Server Connections, select the ellipsis and update the command time-outs
for the OneStream Database Server connection:

Short=90 *mustdo
Large =900 (minimum or 900)

Select File > Save and close the file.
Open the Web Server Configuration file.

Select File > Save and close the file.

Update and Configure IS

1.

2.

On each OneStream server, open the OneStream Server Configuration Utility by clicking
Start > Programs > OneStream Software > Server Configuration Utility.

Right-click the utility and select Run as Administrator.

Upgrade Guide
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Upgrade System Components

3. Choose Tools > Configure IIS.
4. In Configure IIS, specify the following:
a. For Web Site Name, enter the name of the OneStream |IS Website to update.
b. The OneStream App Server, and Web Server sites.
5. Select Update IIS Default Settings.
6. Select options to update IIS for the appropriate websites:
a. Use Web Server Settings: Specify the Web Server site.
b. Use App Server Settings: Specify the App Server site.

c. User Account Type: Specify Custom Account, then enter the user name and
password of the OneStream Service account.

7. Click Update IIS Settings then OK.
8. Repeat these steps to set the appropriate 11S settings for the application pools in IIS.

9. Click Reset lIS.

Test the Windows Client Login Using ClickOnce

1. Using the Microsoft Edge Web Browser, navigate to the OneStream Windows App URL:
¢ On Prem: http://<webserver>:50001/OneStreamWeb
¢ Cloud: https://<customer>.onestreamcloud.com/OneStreamWeb
2. Click Open to launch the ClickOnce Windows app.
3. Confirm that you can log in.
4. From Application, select System Administration then click Connect.
5. Select System > Tools > Environment to identify the application servers and their status.

6. Verify that each server is active.
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Upgrade System Components

Verify the Application
1. Compile all business rules, ensure to:
» Right-click the grid and export any errors for analysis using an Excel file format.
¢ Apply updates as needed.

2. Download and import the Standard Application and Standard System Reports from the
MarketPlace portal on the Solution Exchange.

Upgrade Guide
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Platform Release 8.0 or Later Readiness

Platform Release 8.0 or Later
Readiness

Upgrading your OneStream Platform to Release 8.0 or later requires .NET 6.

Business Rules

NOTE: Users upgrading from Platform Release 8.0 to 8.1 are not expected to
require Business Rule maintenance.
Users upgrading from a Platform Release prior to 8.0 will require Business Rule maintenance as
Platform Release 8.0 includes updates and enhancements to the Business Rules compiler to
improve syntax detection. Administrators must resolve these errors to compile business rules
fully. Warning messages identify line items that will function, but you should update them to
support the latest compiler’s requirements. Resolving these warnings varies. You may be able to
use a provided replacement function or change a function’s properties.

System.Data.SqlClient to Microsoft.Data.SqlClient
Migration

IMPORTANT:

In order to maintain consistency with Microsoft's recommendations, in Platform Release
8.1, the data access driver for SQL Server will be updated from System.Data.SqlClient
to Microsoft.Data.SqlClient. This migration will be automatic and will take place during
the database upgrade process. All references to System.Data.SqlClient will
automatically be upgraded to Microsoft.Data.SqlClient in Business Rules, Member
Formulas, and the like.

NOTE:

These updates will take place automatically during the database upgrade to
Platform Release 8.1, and when using the Load function of Application
Load/Extract, instances of System.Data.SqlClient will automatically convert to
Microsoft.Data.SqlClient.
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Platform Release 8.0 or Later Readiness

IMPORTANT:

If an application was migrated after the Platform Release 8.1 upgrade from Application
Copy (Cloud Administration Tools (CAT)) or a database BACPAC file, then the migration
from System.Data.SqlClient to Microsoft.Data.SqlClient will need to be applied directly
to that application. On-prem customers can run the Upgrade SqlClient Namespace
References from the OneStream Database Configuration utility to replace
System.Data.SqlClient references. SaaS customer can request to have this run by
contacting OneStream Support (support.onestreamsoftware.com).

#% OneStream Database Configuration =

File  Tools

4 Databases
OneStream (RMTHO-L5143\MSSQLSERVER2017)

OneStream_EZCorp (RMTHO-L5143\MSSQLSERVER2(
Edit Database Connection
Onestream_FinanceTest (RMTHO-L5143\MS5QL

Re Datab: Ci ti
OneStream_Framework (RMTHO-L5143\MS5QL: emove Database Connection

Copy Te Clipkoard

OneStream_GolfStreamDema (RMTHO-L51434
OneStream_GolfStreamDemo_2022 (RMTHO-LS
OneStream_MarketPL (RMTHO-L5143\MSSQLSE

Export Table Data To File
Import Table Data From File
Recreate Table And Audit Table While Retaining Data

Upgrade SglClient Namespace References

Upgrade Database Version (8.0.0.0 - 8.1.0.0}

For more information, visit the Platform v8+ Upgrades page on ONECommunity.

Example
Business Rule Updates: Update Using and Import statements to reference

Microsoft.Data.SqlClient using the following code:

C# Prior to 8.1

using System.Data.SqlClient;

SqlConnection connl = new System.Data.SqlClient.SqlConnection();
System.Data.SqlClient.SqlConnection conn2 = (System.Data.SqlClient.SglConnection)conni;

C# For 8.1

using Microsoft.Data.SqlClient;
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Platform Release 8.0 or Later Readiness

SglConnection connl
SqlConnection conn2

new Microsoft.Data.SqlClient.SqlConnection();
(Microsoft.Data.SqlClient.SqlConnection)connl;

Visual Basic Prior to 8.1

Imports System.Data.SqlClient

Dim connl As New System.Data.SqlClient.SqlConnection()
Dim conn2 As System.Data.SqlClient.SqlConnection = CType(connl, System.Data.SqlClient.SqlConnection)

Visual Basic for 8.1

Imports Microsoft.Data.SqlClient

Dim connl As New Microsoft.Data.SqlClient.SqlConnection()
Dim conn2 As SqlConnection = CType(connl, Microsoft.Data.SqlClient.SqlConnection)

Custom DLLs

If your implementation / business rules reference any custom DLLs that are not provided by
OneStream, these DLLs must be .NET 6 compatible. Contact OneStream Support
(support.onestreamsoftware.com) to discuss available upgrade options.

ERPConnect (SAP)

ERPConnect45.dll enabling connection to SAP systems is no longer available in Platform 8.0 and
later. A newer version ERPConnectStandard20.dll is available through the download "DLL
Packages" from the Platform page of the Solution Exchange.

On-Prem Customers:
1. Download ERPConnectStandard20.dll file to your integrations folder.

2. Install the required Visual C++ 2013 Runtime.

3. Download and copy SAP NetWeaver RFC Library DLL (sapnwrfc.dll) to the integrations
folder.
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Platform Release 8.0 or Later Readiness

See Theobald Software ERPConnect Requirements for more information.

4. Modify your business rules to use the ERPConnectStandard20.dll.

Cloud/SaaS Customers: ERPConnectis available through the Smart Integration Connector
(SIC). See ERPConnect section of the SIC Guide for installation details or contact OneStream
Support (support.onestreamsoftware.com) to discuss morel upgrade options.

Smart Integration Connector

Smart Integration Connector is required for OneStream Cloud integration with local customer data
sources when using OneStream Platform Release 8.0 or higher. VPN is no longer supported with
Platform Release 8.0 or higher and will reach end of service for Platform versions prior to version
8 on August 31, 2024.

Authentication

Cloud Customers: OneStream IdentityServer is required for OneStream Platform Release 8.0 or
later.

Self-hosted Customers: No changes necessary. Legacy Authentication support is the standard
for self-hosted customers.

.NET 6 Desktop Runtime and ASP.NET Runtime

To best align with Microsoft's long-term support strategy, OneStream Platform Release 8.0 or
later is built using .NET 6. Platform Release 8.0 or later users are required to use the latest
versions of .NET Desktop Runtime x64 and ASP .NET Core Runtime Hosting Bundle (6.0.14

minimum).
VBA Changes

ProcessSSOAuthenticationAndCreateToken is no longer supported as an authentication option
from VBA scripts. See Visual Basic for Applications (VBA) Procedures for additional details. See
Visual Basic for Applications (VBA) Procedures in the Design and Reference Guide for additional
details.

Client API Changes

Client APl is no longer provided with Platform Release 8.0 or higher. OneStream recommends
Task Scheduler or the REST API to replace existing Client APl use cases.
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Platform Release 8.0 or Later Readiness

Tiles Page

The ClickOnce journey is enhanced to launch the application with a single click of the Open
button while eliminating the tiles page. For more information, see Installation Using ClickOnce in
the Installation and Configuration Guide.For more information, see Installation Using ClickOnce in
the Installation and Configuration Guide.

Help Documentation

Help documentation has moved from within the application to
https://documentation.onestream.com. Clicking the in-app help icon routes you to this site.

Business Rule Groups

In version 8.0 the default for new Business Rule Access or Maintenance Groups is the
Administrators group. This default can be changed by the Server Configuration Utility.

MarketPlace Solution Compatibility

The following MarketPlace Solutions are compatible with OneStream Platform version 8.1.

MarketPlace Solution Version

Account Reconciliations PV800 SV200
Administrator Solution Tools PV620 SV101
Application Control Manager PV740 SV100 (Future Release)
Capital Planning PV620 SV102
Cash Planning PV620 SV102
Cloud Administration Tools PV600 SV101 (Future Release)
Contract Compliance PV620 SV102
Data Entry 123 PV440 SV100
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Platform Release 8.0 or Later Readiness

MarketPlace Solution Version

Dimension Comparison PV600 SV100
Excel Add-in Installer PV710 SV100
File Explorer Manager PV650 SV102
Financial Close PV710 SV201
Guided Reporting PV600 SV102
Help Desk PV640 SV100
Marketplace Solution Tools PV720 SV100
Metadata Builder PV520 SV101
Model Maker PV680 SV201
Parcel Service PV630 SV100
People Planning PV620 SV103

Predictive Analytics 123

PV620 SV102 (Future Release)

Process Blocker PV430 SV100
Process Control Manager PV430 SV101
Provision Request Manager PV440 SV104
Reporting Compliance PV620 SV103
Sales Planning PV620 SV102
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Platform Release 8.0 or Later Readiness

MarketPlace Solution Version

Sample Templates PV600 SV100
Scenario Analysis 123 PV530 SV100
Security Audit Reports PV620 SV101
Snippet Editor PV620 SV100
Standard Application Reports PV610 SV201
Standard Cube View Styles PV410 SV100
Standard System Reports PV430 SV102
System Diagnostics PV620 SV202
Table Data Manager PV620 SV100
Task Manager PV660 SV102
Tax Provision PV620 SV200
Thing Compliance PV620 SV102
Thing Planning PV620 SV101
Train Me PV410 SV100
Transaction Matching PV800 SV200
XML Security Remover PV410 SV100
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Help and Miscellaneous

Help and Miscellaneous

Upgrade Troubleshooting

Incorrect Installation Order

To check that you have the latest .NET versions installed, run the following command in the
PowerShell:

dotnet --info

NOTE: The hosting bundle should be Microsoft.AspNetCore.App 6.0.x and the
desktop runtime should be Microsoft.WindowsDesktop.App 6.0.x

To check that you IS was properly installed, run the following command in the PowerShell:

get-webglobalmodule

I NOTE: The output must contain AspNetCoreModuleV2.

Resolution: Uninstall the hosting bundle and ensure that IIS is properly installed.

Execution Policy when running PowerShell Script
Resolution: Run the following commands in the PowerShell:
* PS C:\WINDOWS\system32> Set-ExecutionPolicy Unrestricted

+ PS C:\WINDOWS\system32> Set-ExecutionPolicy

Internet Explorer End-of-Use

When using ClickOnce, it must be invoked using Microsoft Edge. For more information, see
ClickOnce in the Installation and Configuration Guide.

More details for |IE end-of-use details are as follows:
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Help and Miscellaneous

As of July 2022, if you have an Internet Explorer ClickOnce shortcut to the OneStream Desktop
Client application, it will not launch the application of any version when IE is disabled inside your
organization. Starting with 7.0, newly created shortcuts will be created using Windows
PresentationHost.exe. Upgrading to 7.0 will not automatically update existing shortcuts. You must
manually create new ones or edit existing ones. To update an existing shortcut of any OneStream
platform version, follow these steps:

1. Right-click on the existing desktop shortcut and go to Properties.
2. Copy and paste the text in the Target field into the notepad.

3. Replace this section “C:\Program Files\Internet Explorer\iexplore.exe” with
C:\Windows\System32\PresentationHost.exe-launchApplication (note that the “ “ are
removed).

4. Copy and paste the whole text into the target field inside the shortcut's properties, click
Apply, then click OK.

You will not be able to view embedded external web pages inside OneStream when IE is disabled
inside your organization. Starting with 7.0, the external web pages will be embedded using the
Microsoft Edge WebView2 runtime control. Microsoft automatically installs the WebView2 runtime
on Windows 10 machines. You can verify if the component is installed on your machine through
Add or Remove Programs. It can also be downloaded directly from Microsoft.

Once IE is disabled within your organization, embedded web pages will no longer render inside
OneStream on versions 6.8 and older, even if you have WebView?2 installed. If your application
uses features that embed external web pages, usually through properties that allow pointing to a
URL, an upgrade to 7.0+ will be required with the WebView2 runtime control. Key OneStream
features that enable embedding external web pages:

+ Dashboard component Web Content
¢ Dashboard component File Viewer
¢ Dashboard component Button

o A drill back Business Rule in Transformation Rules Connector
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